※通達信條件警告的全面設置※

一、一般情況下的設置。

1打開預警設置框。在通達信程序的右下角點擊兩個三角的地方。

2.條件預警框出現。

3.點擊條件預警框下面的設置。在出現的設置對話框中,點擊“添加股票”可以添加你需要預警的股票,可以選擇處個板塊導入。

4.點擊“公式設置”選項卡,如下圖。點擊添加公式。

5.出現公式條件預警設置,在選股公式的下拉菜單中,選擇合適的公式。

6.可以看出這里面的公式,都是條件選股公式。沒有其他類型的如技術指標公式。

7.可以根據自己的要求多選擇幾個公式,但要注意的是預警時,只要滿足其中一個條件就會預警,而不是同時全部滿足時預警。

8.點擊條件預警設置中的其它設置選項卡,可以設置預警的聲音。

9.點擊確定后退出,好了只要條件達到,通達信就會給你預警了。

二、多條件同時預警。

上面已經說了,在預警時雖然選擇了多個條件,但只要其中一個條件達到要求,就會預警,而有時我們需要同時滿足兩個條件時才預警,那怎么辦呢?

這就需要借助通達信的公式編輯器了。按ctrl+F運行公式編輯器,把你需要的兩個公式都通過修改的方式粘貼出來,再新建一個公式,把它們合并起來,但最后設置滿足條件時,要把這兩個公式結尾部分的條件用and連接起來,保存后,再到預警中設置就行了。

如連續N 日收陽的公式

{N為參數:1:10:100)}

UP3:= UPNDAY(CLOSE,N));

與macd線買入

DIFF := EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);

DEA := EMA(DIFF,M);

CROSS(DIFF,DEA);

你合成時,就寫成

UP3:= UPNDAY(CLOSE,N));

DIFF := EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);

DEA := EMA(DIFF,M);

UP3 and CROSS(DIFF,DEA);

就行了,注意最后一句。

三、對于其它非條件選股(包括副圖的一樣指標公式)的公式如技術指標選股的公式,與上面一樣,也應該進入公式編輯器中,把這個技術指標公式改編為條件選股公式才可以使用。

如副圖中“主力散記籌碼線”公式。

原公式是:

VAR1:=1;

VAR2:=1/WINNER(CLOSE);

VAR3:=MA(CLOSE,13);

VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);

VAR5:=LLV(LOW,75);

VAR6:=HHV(HIGH,75);

VAR7:=(VAR6-VAR5)/100;

VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);

VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);

VARA:=3*VAR8-2*SMA(VAR8,15,1);

VARB:=3*VAR9-2*SMA(VAR9,15,1);

VARC:=100-VARB;

主力: (100-VARA)*VAR1,COLOR0099FF;

散戶: MA(WINNER(CLOSE*0.95)*100,3)*VAR1,COLORYELLOW;

新莊: (100-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0))*VAR1,COLORGREEN,LINETHICK1,POINTDOT ;

VARD:=散戶>VAR4;

VARE:=REF(LOW,1)*0.9;

VARF:=LOW*0.9;

VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;

VAR11:=EMA(VAR10,30);

VAR12:=CLOSE-REF(CLOSE,1);

VAR13:=MAX(VAR12,0);

VAR14:=ABS(VAR12);

VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;

VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;

VAR17:=BARSCOUNT(CLOSE);

VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;

VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;

VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);

VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

VAR1D:=SMA(VAR1C,4,1);

VAR1E:=SMA(VAR1D,3,1);

VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;

STICKLINE(VARD,VAR4,散戶,5,0),COLORWHITE;

STICKLINE(1,新莊,100,1,0),COLORGREEN;

STICKLINE(VAR20,0,80,5,0),COLORRED,LINETHICK3 ;

100,COLORGREEN ,LINETHICK2 ;

0,COLORYELLOW ,LINETHICK2 ;

中線: 15,COLORBLUE ,LINETHICK2 ;

根據使用這的情況得知,當主力線逐漸下移進,該股就會開始拉升,形勢變好。為此可以把這個公式改編成這樣一個條件選股公式。

VAR1:=1;

VAR2:=1/WINNER(CLOSE);

VAR3:=MA(CLOSE,13);

VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);

VAR5:=LLV(LOW,75);

VAR6:=HHV(HIGH,75);

VAR7:=(VAR6-VAR5)/100;

VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);

VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);

VARA:=3*VAR8-2*SMA(VAR8,15,1);

VARB:=3*VAR9-2*SMA(VAR9,15,1);

VARC:=100-VARB;

主力:=(100-VARA)*VAR1;

EVERY(主力<REF(主力,1),1);

很明顯,因為不需要畫線,也不需要其它函數,所以我只用了原公式中前半部分(藍色字體的部分),而修改的也只有后面一句(改編后的紅色字體部分),又加上了一句用來判斷的語句。

保存后就可以在條件預警中使用了。

免責聲明:本文僅代表文章作者的個人觀點,與本站無關。其原創性、真實性以及文中陳述文字和內容未經本站證實,對本文以及其中全部或者部分內容文字的真實性、完整性和原創性本站不作任何保證或承諾,請讀者僅作參考,并自行核實相關內容。

http://image95.pinlue.com/image/17.jpg
分享
評論
首頁
(-^O^-)MG金字塔的财富爆分打法 排列5开奖公告 新浪彩票开奖 幸运赛车前二 足球nba比分直播 手机经典单机麻将游戏 好运彩app官方版下载 在哪买北单 红包麻将赢红包 新西兰五分彩开奖软件 澳洲幸运8开奖查询 足彩310 比特币收益计算方式 双色球的篮球投注技巧 加拿大统计硕士 山西11选5推荐号码推荐 哈尔滨麻将千术教学