均線角度

當前位置:→公式在線網>通達信公式> 正文362℃

以下是應朋友請求開發均線角度(色柱)指標分享給大家(無源碼的請下載附件導入)

有盆友問俺有沒有均線角度的指標,俺找了找,是很久以前用過的指標了,現在從新翻找出來,分享給大家:

首先申明,俺不大會用該指標,據說是拿來選股的。

圖片說明:紅綠空心柱子為短期均線角度jd1,黃青實心柱子為短期均線角度jd2;土黃白灰色帶為中期均線角度jd3;底邊為長期均線角度背景。

均線角度

a:=(h+l+0+c)/4;

b:=(ma(a,n1)-ref(ma(a,n1),1))/0.015*avedev(a,n1);

{O(∩_∩)O~,不需要的把前面刪了}

{正文開始}

{n1:2,200,5}

{n2:2,200,10}

{n3:2,300,25}

{n4:2,200,60}

n1:=5;n2:=10;n3:=25;n4:=60;

JD1:ATAN((MA(C,N1)/REF(MA(C,N1),1)-1)*100)*180/3.1816,NODRAW;

JD2:ATAN((MA(C,N2)/REF(MA(C,N2),1)-1)*100)*180/3.1816,NODRAW;

JD3:ATAN((MA(C,N3)/REF(MA(C,N3),1)-1)*100)*180/3.1816,NODRAW;

JD4:ATAN((MA(C,N4)/REF(MA(C,N4),1)-1)*100)*180/3.1816,NODRAW;

DRAWBAND(JD3,RGB(182,99,11),0,RGB(88,77,66));

STICKLINE(JD1>=0,0,JD1,2,2),COLORRED;

STICKLINE(JD1<=0,0,JD1,2,2),COLORGREEN;

STICKLINE(JD2>=0,0,JD2,0.8,0),COLORYELLOW;

STICKLINE(JD2<=0,0,JD2,0.8,0),COLORLICYAN;

STICKLINE(JD4>=0,-80,-65,1,0),COLORRED;

STICKLINE(JD4<=0,-80,-65,1,0),COLORBLUE;

--------------------------------

當前位置:→公式在線網>通達信公式> 正文1560℃

以下是通達信5日角度>60+過前高+虛擬倍量+神奇均線=強勢牛股公式(無源碼的請下載附件導入)

通達信5日角度>60+過前高+虛擬倍量+神奇均線=強勢牛股公式

強勢牛股

AA:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);

預測:=AA/10000;

指數百萬個萬手:=VOL/10000;

TY:=C;

A11:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A11,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);

前期高位:=REF(H,BARSLAST(HD));

X:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>60;

倍量:=預測>=REF(指數百萬個萬手,1)*1.2;

XG:=CROSS(C,前期高位) OR C>前期高位;

VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;

A1:=(EMA(VAR1,3)+EMA(VAR1,6)+EMA(VAR1,12)+EMA(VAR1,24))/4;

A2:=EMA(A1,2);{公式在線提供:www.gszx.com.cn}

A3:=EMA(A2,2);

A4:=EMA(A3,2);

A5:=EMA(A4,2);

A6:=EMA(A5,2);

A7:=EMA(A6,2);

A8:=EMA(VAR1,2.78)*1.028,LINETHICK3;

A9:=MA(OPEN,3.2)*1.028,LINETHICK3;

安全線:=EMA(CLOSE,55);

CLOSE>OPEN AND A1>A2 AND A2>A3 AND A3>A4 AND A4>A5 AND A5>A6 AND A6>A7 AND

XG AND CLOSE>OPEN AND X AND 倍量 AND C<20;

-------------------------------------------------------------

以下是用分時均線角度選股你試驗過嗎(源碼.附圖.說明.大智慧用)(無源碼的請下載附件導入)

用分時均線角度選股你試驗過嗎(源碼.附圖.說明.大智慧用)

用分時均線角度選股你試驗過嗎.在分時看盤時如果均線的角度80度以上.這個股票一定是今天的強勢股.當然選股時你用的角度是可變的.你看根據市場的情況調整.目的和以前的要求一樣.

【1】選出的股票不要太多.【2】成功率要高.【3】角度可隨市場調整.看看圖就明白沒有太難的內容.【4】時間不要太早.市場是瞬息萬變的.最好14時以后.還要防備尾盤跳水.

{均線角度[分時]}

tt:=BARSCOUNT(C);

CC:=CLOSE;

zz:=SUM(AMOUNT,tt)/SUM(VOL*100,tt);

zz1:=BETWEEN(C/zz,1.05,0.95);

均線:=IF(zz1=0,MA(C,TT),zz);

均線角度:ATAN(均線)*180/3.1416>89;

-----------------------------------------

以下是量價角度副圖源碼貼圖(無源碼的請下載附件導入)

MV5:=EMA(V,5);

MA5:=EMA(C,5);

MV5角度:=ATAN((MV5/REF(MV5,1)-1)*100)*180/3.1416;

MA5角度:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;

量角:IF(MV5角度>30,MV5角度,0),COLOR0000FF,LINETHICK0;

價角:IF(MA5角度>0,MA5角度,MA5角度),COLORFFFFFF,LINETHICK2;

PARTLINE(價角,價角>REF(價角,1) AND 價角>=0,RGB(255,0,0),價角<REF(價角,1) AND 價角>0,RGB(0,255,0)),LINETHICK2;

QSXS:=MA5角度>REF(MA5角度,1) AND MV5角度>80;

∠45↑: IF(CROSS(MA5角度,30),1,0),COLORFFFFFF,POINTDOT,LINETHICK0;

買強:IF(MA5角度>45 AND QSXS,10,0),COLOR00FFFF,POINTDOT,LINETHICK0;

防火:IF(MA5角度>70 AND MV5角度>80,20,0),COLORFF00FF,POINTDOT,LINETHICK0;

賣瘋:IF(MA5角度>80 AND MV5角度>80,30,0),COLOR0000FF,POINTDOT,LINETHICK0;

WK:=MA5角度=LLV(MA5角度,3) AND MA5角度-HHV(MA5角度,4)<=0-50;

挖坑:IF(WK AND COUNT(買強 OR 防火,6),0-30,0),COLOR00FF00;

海底:IF(MA5角度<0-75,0-50,0-75),COLORFF8800;

{以下設置副圖顯示方式}

STICKLINE(MV5角度>30,MV5角度,30,0.1,0),COLOR0000FF;

STICKLINE(買強,0,10,4,0),COLOR00FFFF;

STICKLINE(防火,10,20,4,0),COLORFF00FF;

STICKLINE(賣瘋,20,30,4,0),COLOR0000FF;

DRAWTEXT(∠45↑,30, "↑"),COLORFFFFFF;

VERTLINE(∠45↑,2),COLOR00FFFF;

30,COLORFFFFFF;

M3:=MA(C,3);

M5:=MA(C,5);

N1:=BARSLAST(CROSS(M3,M5));

N2:=BARSLAST(CROSS(M5,M3));

N:=IF(N1<N2,N1+1,0-N2-1);

STICKLINE(N>0,0-75,0-75+N*2,8,0),COLOR0000FF;

STICKLINE(N<0,0-75,0-75+N*2,8,0),COLORFFFF00;

------------------------------------------------------

以下是SAR+強度角度線非常實用的副圖指標?。o源碼的請下載附件導入)

SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);

AA10:MA(CLOSE,8),COLOR0000FF;AA12:MA(CLOSE,12),COLOR0000FF;BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);

BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);MA13:=MA(CLOSE,13);

STICKLINE((((AA12 <= AA10) AND (BB12 >= 1)) AND (BB10 >= 1)),AA10,AA12,4,0),COLOR0080FF;

STICKLINE((((AA12 >= AA10) AND (BB10 <= 1)) AND (BB10 <= 1)),AA10,AA12,4,0),COLOR00FF00;

X1:=(C+L+H)/3;BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;

EMA8:=EMA(C,8);DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),

EMA8,"∠45上升"),COLORWHITE;壓力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;

支撐:MA(REF(LLV(C,30),1),2),COLORABFF46; AA1:=AMOUNT/V;BB1:=L<AA1*0.9;

CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;DD1:=L<MA(C,5)*0.921;EE1:=V<MA(V,5)*1.5;

A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);

黑馬線:=EMA(A51,5);A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;

趨勢線:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));

LC:=REF(CLOSE,1);RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);

VAR2:=LLV(LOW,27);VAR3:=HHV(HIGH,34);VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*25;

MTM:=C-REF(C,1);DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

上一篇:一個計算股票成本的公式供大家參考 下一篇:我心飛揚 副圖源碼 信號準 中期選股參考

上一篇:通達信跟莊進退副圖選股公式 下一篇:通達信關注股指標公式

免責聲明:本文僅代表文章作者的個人觀點,與本站無關。其原創性、真實性以及文中陳述文字和內容未經本站證實,對本文以及其中全部或者部分內容文字的真實性、完整性和原創性本站不作任何保證或承諾,請讀者僅作參考,并自行核實相關內容。

http://image95.pinlue.com/image/14.jpg
分享
評論
首頁
(-^O^-)MG金字塔的财富爆分打法 长春麻将具体规则图解 新疆时时彩的骗局 辽宁cba总决赛总比分 mg真人电子游戏 赌北京赛车输了好多钱 重庆时时彩投注时间表 30选5走势图表 三昇体育真假 上海麻将作弊技术 云南福彩中奖记录 真钱炸金花下载官网 黑龙江22选5历史开奖结果查询 辛运28预测 十一运夺金app 北京麻将小游戏下载 极速飞艇网站